www.amicon.ru ООО "АМИКОН" - Защита информации, Межсетевые экраны, VPN-построители, ЭЦП. Контакты  |  Написать нам
тел.:  
/495/ 797- 6412
/495/ 797- 6413
/495/ 781- 8922
/495/ 781- 8923
Работа ФПСУ-IP/клиент в будущих версиях MacOS.


Данная проблема связана с кардинальным изменением API операционной системы, используемого при разработке ПО ПАК "ФПСУ-IP/клиент". Новый API, к сожалению, пока не имеет необходимой для его работы функциональности, что требует кардинальной переделки ПО и принципов его работы в данной ОС. При этом, используемый в настоящий момент API будет полностью отключен.

Разработка новой версии уже ведется, но с учетом всех перечисленных ограничений и непрерывно вносимых компанией Apple изменений в API.

Мы делаем все возможное, чтобы совместимая версия ПО ПАК "ФПСУ-IP/клиент" была доступна к моменту выхода нового релиза операционной системы MacOS.

В актуальной версии ОС 10.15 поддерживаются оба API - старый и новый. Начиная с релиза 10.15.4 уже выдается предупреждение, что старый API скоро будет отключен, но не указывается с какой  именно версии. Желательно воздержаться от установки новых версий ОС,  чтобы не нарушить работу ПО ПАК "ФПСУ-IP/клиент", особенно в условиях массовой удаленной работы.


Новость добавлена: 2020-04-01 20:05:21


<< Вернуться